PHP Multiverzió, azaz a PHP verziók beállítása

Szervereinken mindenhol elérhető a PHP környezet több verziója, beleértve a legfrissebbeket is.

PHP verzió beállítása

A következő lépések szükségesek:

  1.  Lépj be  a cPanelbe, keresd meg a Szoftver szekciót és azon belül a Select PHP Version-t. Kattints rá!
  2.  A megjelenő oldalon bal oldalon felül látszik az alapértelmezett PHP verzió - általában az 5.6. Ha ezen módosítani szeretnél, akkor a legördülő menüből ki kell választani a megfelelő verziót, majd a Set as current-re kell kattintani.
  3.  Az alább látható modulok közül ki kell választani mindazokat, amiket használni szeretnénk - általában van alapértelmezett beállítás, de nem mindig - majd a Save gombra kell kattintani alul.

PHP futtatási környezet beállítása

  1.  Jobb oldalon felül a Switch to PHP Options linkre kattintva jutunk el a megfelelő oldalra.
  2.  Itt a megfelelő sor melletti értékre kattintva tudjuk módosítani azt. Pl. ha a max_execution_time értékét szeretnénk az alapértelmezett 30-ról emelni - ez gyakran okozhatja azt, hogy az oldalunk "lefagy" vagy 503-as hibát generál -, akkor rákattintva beírhatjuk az általunk választott értéket, pl. 300-at. Utána az Alkalmazás-ra kell kattintanunk a beállításhoz.
  3. Ha minden értéket megadtunk, amit szerettünk volna, akkor alul a Mentés gombbal tudjuk elmenteni a módosításokat.

Készítettünk egy videót az egész folyamatról, ami itt tekinthető meg:

PHP futtatási környezet beállítások videó

  • PHP, PHP verzió, PHP multiverzió, PHP környezeti változók, PHP modulok
  • 0 A felhasználók hasznosnak találták ezt
Hasznosnak találta ezt a választ?

Kapcsolódó cikkek

Register_Globals és más php kérdések

Tisztelt Ügyfelünk! Tárhelyszolgáltatásunk természetesen a legújabb PHP futtatási környezetet...